| SUMMARY = "AT-SPI 2 Toolkit Bridge" |
| LICENSE = "LGPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886" |
| |
| MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" |
| |
| SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz" |
| SRC_URI[md5sum] = "8936488c8cdce0e158f80b2e247527f9" |
| SRC_URI[sha256sum] = "78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9" |
| |
| DEPENDS = "dbus glib-2.0 atk at-spi2-core" |
| |
| inherit autotools pkgconfig distro_features_check |
| |
| # The at-spi2-core requires x11 in DISTRO_FEATURES |
| REQUIRED_DISTRO_FEATURES = "x11" |
| |
| PACKAGES =+ "${PN}-gnome ${PN}-gtk2" |
| |
| FILES_${PN}-gnome = "${libdir}/gnome-settings-daemon-3.0/gtk-modules" |
| FILES_${PN}-gtk2 = "${libdir}/gtk-2.0/modules/libatk-bridge.*" |
| FILES_${PN}-dbg += "${libdir}/gtk-2.0/modules/.debug" |