| SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| HOMEPAGE = "https://pypi.org/project/setuptools" |
| LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6" |
| SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" |
| SRC_URI += "file://0001-change-shebang-to-python3.patch \ |
| file://reproducibility.patch" |
| SRC_URI[sha256sum] = "401cbf33a7bf817d08014d51560fc003b895c4cdc1a5b521ad2969e928a07535" |
| DEPENDS += "${PYTHON_PN}" |
| ${PYTHON_PN}-compression \ |
| ${PYTHON_PN}-pkg-resources \ |
| install -d ${D}${PYTHON_SITEPACKAGES_DIR} |
| BBCLASSEXTEND = "native nativesdk" |
| # The pkg-resources module can be used by itself, without the package downloader |
| # and easy_install. Ship it in a separate package so that it can be used by |
| PACKAGES =+ "${PYTHON_PN}-pkg-resources " |
| FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" |
| RDEPENDS_${PYTHON_PN}-pkg-resources = "\ |
| ${PYTHON_PN}-compression \ |