| require recipes-graphics/xorg-app/xorg-app-common.inc |
| SUMMARY = "xterm is the standard terminal emulator for the X Window System" |
| DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses" |
| |
| LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=996b1ce0584c0747b17b57654cc81e8e" |
| |
| SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| file://0001-Add-configure-time-check-for-setsid.patch \ |
| " |
| |
| SRC_URI[md5sum] = "247c30ebfa44623f3a2d100e0cae5c7f" |
| SRC_URI[sha256sum] = "e521d3ee9def61f5d5c911afc74dd5c3a56ce147c7071c74023ea24cac9bb768" |
| PACKAGECONFIG ?= "" |
| PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native" |
| |
| EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \ |
| --x-libraries=${STAGING_LIBDIR} \ |
| FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \ |
| --disable-imake \ |
| --disable-rpath-hack \ |
| --disable-setuid \ |
| --with-app-defaults=${datadir}/X11/app-defaults \ |
| " |
| |
| B = "${S}" |
| |
| do_configure() { |
| gnu-configize --force |
| sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure |
| oe_runconf |
| } |
| |
| # busybox can supply resize too |
| inherit update-alternatives |
| |
| ALTERNATIVE_${PN} = "resize" |