| SUMMARY = "The extensible, standards compliant build backend used by Hatch" |
| HOMEPAGE = "https://hatch.pypa.io/" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9" |
| |
| inherit pypi python_hatchling |
| |
| DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native" |
| DEPENDS:remove:class-native = "python3-hatchling-native" |
| |
| SRC_URI[sha256sum] = "a263a8c50817cd2dfcd4dd6d0d55a5ebcb078eeec9858cc3d056314b3438ec8f" |
| |
| do_compile:prepend() { |
| export PYTHONPATH=src |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |