| SUMMARY = "Open Package Manager" |
| SUMMARY_libopkg = "Open Package Manager library" |
| SECTION = "base" |
| HOMEPAGE = "http://code.google.com/p/opkg/" |
| BUGTRACKER = "http://code.google.com/p/opkg/issues/list" |
| LICENSE = "GPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" |
| |
| DEPENDS = "libarchive" |
| |
| PE = "1" |
| |
| SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| file://opkg.conf \ |
| file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ |
| file://0001-libopkg-add-add-ignore-recommends-option.patch \ |
| " |
| |
| SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5" |
| SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe" |
| |
| inherit autotools pkgconfig systemd |
| |
| target_localstatedir := "${localstatedir}" |
| OPKGLIBDIR = "${target_localstatedir}/lib" |
| |
| PACKAGECONFIG ??= "libsolv" |
| |
| PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" |
| PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" |
| PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" |
| PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" |
| PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" |
| |
| EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" |
| |
| do_install_append () { |
| install -d ${D}${sysconfdir}/opkg |
| install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf |
| echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf |
| |
| # We need to create the lock directory |
| install -d ${D}${OPKGLIBDIR}/opkg |
| } |
| |
| RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" |
| RDEPENDS_${PN}_class-native = "" |
| RDEPENDS_${PN}_class-nativesdk = "" |
| RREPLACES_${PN} = "opkg-nogpg opkg-collateral" |
| RCONFLICTS_${PN} = "opkg-collateral" |
| RPROVIDES_${PN} = "opkg-collateral" |
| |
| PACKAGES =+ "libopkg" |
| |
| FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" |