| SUMMARY = "Window navigation construction toolkit" |
| LICENSE = "LGPL-2.0-only" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| |
| BPN = "libwnck" |
| |
| SECTION = "x11/libs" |
| DEPENDS = "intltool-native gnome-common-native gtk+3 gdk-pixbuf-native" |
| |
| PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| PACKAGECONFIG[x11] = "-Dstartup_notification=enabled,-Dstartup_notification=disabled,startup-notification libxres" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| GTKDOC_MESON_OPTION = "gtk_doc" |
| GIR_MESON_ENABLE_FLAG = 'enabled' |
| GIR_MESON_DISABLE_FLAG = 'disabled' |
| |
| inherit gnomebase gobject-introspection gtk-doc gettext features_check |
| |
| def gnome_verdir(v): |
| return oe.utils.trim_version(v, 1) |
| |
| SRC_URI[archive.sha256sum] = "03134fa114ef3fbe34075aa83678f58aa2debe9fcef4ea23c0779e28601d6611" |
| |
| # gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG. |
| # cairo would at least needed to be built with xlib. |
| ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |