Create service files to remove read-write UBI volumes

Perform the opposite operations in reverse order as the
ubimount service file. Create two service files to remove
the rw UBI volumes:
  A template service file that takes the version id and
    removes the pnor-rw-<versionid> volumes. This can be
    used by the Object.Delete interface implementation
    to remove a software version.
  A service file that removes the single pnor-prsv volume.
    This and the template service file can be called by
    the FactoryReset interface implementation to remove
    all read-write volumes.

Closes openbmc/openbmc#1615

Change-Id: I079eb0fdb7e444434f57abf0421f55864dfb9703
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
index 3201c69..1b426d0 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/flash/openpower-software-manager.bb
@@ -28,6 +28,8 @@
 SYSTEMD_SERVICE_${PN} += " \
         obmc-flash-bios-ubiattach.service \
         obmc-flash-bios-ubimount@.service \
+        obmc-flash-bios-ubiumount-prsv.service \
+        obmc-flash-bios-ubiumount-rw@.service \
         obmc-flash-bios-squashfsmount@.service \
         "