| SECTION = "devel" |
| SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128" |
| |
| inherit module |
| |
| COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux' |
| |
| SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| " |
| |
| SRC_URI[md5sum] = "2e3bc8cfb264fa13f374618b46f170e7" |
| SRC_URI[sha256sum] = "8a42240813b8fd1d001835cd6f5ec687f7d7f3b26070d4e21604c35a51a6441d" |
| |
| export INSTALL_MOD_DIR="kernel/lttng-modules" |
| |
| EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| |
| do_install_append() { |
| # Delete empty directories to avoid QA failures if no modules were built |
| find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| } |
| |
| python do_package_prepend() { |
| if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| } |
| |
| BBCLASSEXTEND = "devupstream:target" |
| LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=3f882d431dc0f32f1f44c0707aa41128" |
| DEFAULT_PREFERENCE_class-devupstream = "-1" |
| SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.11 \ |
| file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \ |
| file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \ |
| " |
| SRCREV_class-devupstream = "17c413953603f063f2a9d6c3788bec914ce6f955" |
| PV_class-devupstream = "2.11.2+git${SRCPV}" |
| S_class-devupstream = "${WORKDIR}/git" |
| SRCREV_FORMAT ?= "lttng_git" |