| LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e" |
| ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \ |
| ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \ |
| SRCREV = "4a0e1a0cf378e7bf4909c2ea8fc6e77e0d77ca6d" |
| SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1" |
| SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket" |
| inherit pkgconfig meson ptest |
| -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \ |
| install -d ${D}${PTEST_PATH}/test |
| cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/ |
| FILES:${PN} += "${datadir}/** " |
| USERADD_PACKAGES = "${PN}" |
| # add a user called httpd for the server to assume |
| USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb" |
| GROUPADD_PARAM:${PN} = "web; redfish" |
| FULL_OPTIMIZATION = "-Os " |