DESCRIPTION = "Core utilities for Python packages" | |
HOMEPAGE = "https://github.com/pypa/packaging" | |
LICENSE = "Apache-2.0 | BSD-2-Clause" | |
LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91" | |
SRC_URI[sha256sum] = "b6ad297f8907de0fa2fe1ccbd26fdaf387f5f47c7275fedf8cce89f99446cf97" | |
inherit pypi python_flit_core | |
BBCLASSEXTEND = "native nativesdk" | |
# Bootstrap the native build | |
DEPENDS:remove:class-native = "python3-build-native" | |
do_compile:class-native () { | |
python_flit_core_do_manual_build | |
} |