| DESCRIPTION = "Python documentation generator" |
| HOMEPAGE = "http://sphinx-doc.org/" |
| SECTION = "devel/python" |
| LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=066da51ab732319a06beae4f10788577" |
| |
| PYPI_PACKAGE = "Sphinx" |
| |
| SRC_URI[sha256sum] = "0dac3b698538ffef41716cf97ba26c1c7788dba73ce6f150c1ff5b4720786dd2" |
| |
| inherit python_flit_core pypi |
| |
| |
| do_install:append () { |
| # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?) |
| rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex* |
| } |
| |
| RDEPENDS:${PN} = "\ |
| python3-alabaster \ |
| python3-babel \ |
| python3-docutils \ |
| python3-imagesize \ |
| python3-jinja2 \ |
| python3-packaging \ |
| python3-pygments \ |
| python3-requests \ |
| python3-snowballstemmer \ |
| python3-sphinxcontrib-applehelp \ |
| python3-sphinxcontrib-devhelp \ |
| python3-sphinxcontrib-htmlhelp \ |
| python3-sphinxcontrib-jsmath \ |
| python3-sphinxcontrib-qthelp \ |
| python3-sphinxcontrib-serializinghtml \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |