| # Base image version class extension |
| DEPENDS:append = " os-release" |
| path = d.getVar('STAGING_DIR_TARGET', True) + d.getVar('sysconfdir', True) |
| path = os.path.join(path, 'os-release') |
| parser = configparser.ConfigParser(strict=False) |
| with open(path, 'r') as fd: |
| buf = '[root]\n' + fd.read() |
| version = parser['root']['VERSION_ID'] |
| version = do_get_version(d) |
| version = version.strip('"') |
| version_id = (hashlib.sha512(version.encode('utf-8')).hexdigest())[:8] |
| path = d.getVar('STAGING_DIR_TARGET', True) + d.getVar('sysconfdir', True) |
| path = os.path.join(path, 'os-release') |
| parser = configparser.ConfigParser(strict=False) |
| with open(path, 'r') as fd: |
| buf = '[root]\n' + fd.read() |
| build_id = parser['root']['BUILD_ID'] |