| SUMMARY = "Extensible memoizing collections and decorators" |
| HOMEPAGE = "https://github.com/tkem/cachetools" |
| DESCRIPTION = "This module provides various memoizing \ |
| collections and decorators, including variants of the \ |
| Python 3 Standard Library @lru_cache function decorator." |
| SECTION = "devel/python" |
| |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362" |
| |
| inherit pypi setuptools3 ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS_${PN} += " \ |
| ${PYTHON_PN}-math \ |
| " |
| |
| RDEPENDS_${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| SRC_URI[md5sum] = "9d54dacd774e2af7e9a50741386f5455" |
| SRC_URI[sha256sum] = "3796e1de094f0eaca982441c92ce96c68c89cced4cd97721ab297ea4b16db90e" |
| |
| BBCLASSEXTEND = "native nativesdk" |