meta-raspberrypi: subtree update:e2c1992955..cc6074c660

Andrei Gherzan (1):
      sdcard_image-rpi.bbclass: Fix when RPI_SDIMG_EXTRA_DEPENDS not defined

Christopher Clark (2):
      sdcard_image-rpi.bbclass: enable extensible inclusion into boot
      docs/extra-build-config.md: document vars to add to boot partition

Fabio Berton (1):
      u-boot: Move fw_env.config to u-boot append

Jakub Luzny (2):
      rpi-config: Add CAN_OSCILLATOR variable to set mcp2515 crystal frequency
      docs/extra-build-config.md: Document CAN_OSCILLATOR variable

Jeff Ithier (1):
      Generalize the naming of the bootfiles deploy directory

Martin Jansa (1):
      linux-raspberrypi-5.4: bump SRCREV to latest to fix perf build

Pierre-Jean Texier (3):
      rpi-default-versions: Switch defaults to 5.4
      raspberrypi-firmware: update to current HEAD
      linux-raspberrypi: bump to revision 4b945d5

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I50eca26a801bfe014d3cea271f0cb91e7b653445
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb
new file mode 100644
index 0000000..80e226d
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/bootfiles.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Closed source binary files to help boot all raspberry pi devices."
+LICENSE = "Broadcom-RPi"
+
+LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d"
+
+inherit deploy nopackages
+
+include recipes-bsp/common/raspberrypi-firmware.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+DEPENDS = "rpi-config"
+
+COMPATIBLE_MACHINE = "^rpi$"
+
+S = "${RPIFW_S}/boot"
+
+PR = "r3"
+
+do_deploy() {
+    install -d ${DEPLOYDIR}/${PN}
+
+    for i in ${S}/*.elf ; do
+        cp $i ${DEPLOYDIR}/${PN}
+    done
+    for i in ${S}/*.dat ; do
+        cp $i ${DEPLOYDIR}/${PN}
+    done
+    for i in ${S}/*.bin ; do
+        cp $i ${DEPLOYDIR}/${PN}
+    done
+
+    # Add stamp in deploy directory
+    touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
+}
+
+do_deploy[depends] += "rpi-config:do_deploy"
+
+addtask deploy before do_build after do_install
+do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+