| # LDSHARED is the ld *command* used to create shared library |
| export LDSHARED = "${CCLD} -shared" |
| # LDXXSHARED is the ld *command* used to create shared library of C++ |
| export LDCXXSHARED = "${CXX} -shared" |
| # CCSHARED are the C *flags* used to create objects to go into a shared |
| export CCSHARED = "-fPIC -DPIC" |
| # LINKFORSHARED are the flags passed to the $(CC) command that links |
| export LINKFORSHARED = "{SECURITY_CFLAGS} -Xlinker -export-dynamic" |
| FILES_${PN} += "${libdir}/* ${libdir}/${PYTHON_DIR}/*" |
| FILES_${PN}-staticdev += "\ |
| ${PYTHON_SITEPACKAGES_DIR}/*.a \ |
| ${PYTHON_SITEPACKAGES_DIR}/*.la \ |