| SUMMARY = "An HTTP library implementation in C" |
| HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| BUGTRACKER = "https://bugzilla.gnome.org/" |
| SECTION = "x11/gnome/libs" |
| LICENSE = "LGPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| |
| DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| |
| SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| |
| SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz \ |
| file://0001-Do-not-enforce-no-introspection-when-cross-building.patch \ |
| " |
| SRC_URI[md5sum] = "66c2ae89d6031b01337d78a2c57c75d5" |
| SRC_URI[sha256sum] = "bd2ea602eba642509672812f3c99b77cbec2f3de02ba1cc8cb7206bf7de0ae2a" |
| |
| S = "${WORKDIR}/libsoup-${PV}" |
| |
| inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| |
| # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| PACKAGECONFIG ??= "" |
| PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| PACKAGECONFIG[gssapi] = "-Dgssapi=true,-Dgssapi=false,krb5" |
| |
| EXTRA_OEMESON_append = " -Dvapi=false" |
| |
| GTKDOC_MESON_OPTION = "doc" |
| |
| # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| # and will therefore become subject to renaming by debian.bbclass. Prevent |
| # renaming in order to keep the package name consistent regardless of whether |
| # gnome support is enabled or disabled. |
| DEBIAN_NOAUTONAME_${PN} = "1" |
| |
| # glib-networking is needed for SSL, proxies, etc. |
| RRECOMMENDS_${PN} = "glib-networking" |
| |
| BBCLASSEXTEND = "native" |