| SUMMARY = "Power manager for the Xfce desktop environment" |
| HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager" |
| SECTION = "x11" |
| |
| LICENSE = "GPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| |
| inherit xfce distro_features_check |
| |
| REQUIRED_DISTRO_FEATURES = "x11" |
| |
| DEPENDS += "gtk+3 glib-2.0 dbus-glib xfconf libxfce4ui libxfce4util libnotify \ |
| libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver" |
| |
| SRC_URI[md5sum] = "17f0e6464ad6b3bc6a657f595bf91430" |
| SRC_URI[sha256sum] = "1ea825452343b895566068018b6d5078608f8f46ce8075ba6bbb4b848f48656b" |
| |
| EXTRA_OECONF = " \ |
| --enable-network-manager \ |
| --enable-panel-plugins \ |
| " |
| |
| PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit" |
| |
| PACKAGES += "xfce4-powermanager-plugin" |
| |
| FILES_${PN} += " \ |
| ${datadir}/polkit-1 \ |
| ${datadir}/appdata \ |
| " |
| |
| FILES_xfce4-powermanager-plugin = " \ |
| ${libdir}/xfce4 \ |
| ${datadir}/xfce4 \ |
| " |
| |
| RDEPENDS_xfce4-powermanager-plugin = "${PN}" |
| RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}" |
| |
| # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin |
| RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |
| RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin" |