| SUMMARY = "nanomsg-next-generation -- light-weight brokerless messaging" |
| DESCRIPTION = "NNG, like its predecessors nanomsg (and to some extent ZeroMQ), is a lightweight, broker-less library, offering a simple API to solve common recurring messaging problems, such as publish/subscribe, RPC-style request/reply, or service discovery." |
| HOMEPAGE = "https://github.com/nanomsg/nng" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a19b15be6e844b39a54de2ef665bd6de" |
| |
| SECTION = "libs/networking" |
| |
| SRCREV = "53ae1a5ab37fdfc9ad5c236df3eaf4dd63f0fee9" |
| |
| SRC_URI = "git://github.com/nanomsg/nng.git;branch=v1.2.x" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit cmake pkgconfig |
| |
| EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON" |
| |
| PACKAGECONFIG ??= "" |
| |
| PACKAGECONFIG[mbedtls] = "-DNNG_ENABLE_TLS=ON,-DNNG_ENABLE_TLS=OFF,mbedtls" |