| SUMMARY = "System load testing utility" |
| DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/" |
| LICENSE = "GPLv2" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| |
| SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ |
| file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \ |
| file://0001-bash-completion-remove-the-shebang-at-the-start.patch \ |
| " |
| SRC_URI[md5sum] = "46aa41d37690324ceab4febfcc549018" |
| SRC_URI[sha256sum] = "d09dd2a1aea549e478995bf9be90b38906a4cdf33ea7b245ef9d46aa5213c074" |
| |
| DEPENDS = "coreutils-native" |
| |
| PROVIDES = "stress" |
| RPROVIDES_${PN} = "stress" |
| RREPLACES_${PN} = "stress" |
| RCONFLICTS_${PN} = "stress" |
| |
| inherit bash-completion |
| |
| do_install() { |
| oe_runmake DESTDIR=${D} install |
| } |