| SUMMARY = "Userspace tools for MMC/SD devices" |
| HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/" |
| LICENSE = "GPLv2" |
| LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0" |
| |
| SRCBRANCH ?= "master" |
| SRCREV = "44f94b925894577f9ffcf2c418dd013a5e582648" |
| |
| PV = "0.1" |
| |
| SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRCBRANCH}" |
| |
| S = "${WORKDIR}/git" |
| |
| CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__" |
| CFLAGS_append_mips64 = " -D__SANE_USERSPACE_TYPES__" |
| CFLAGS_append_mips64n32 = " -D__SANE_USERSPACE_TYPES__" |
| |
| do_install() { |
| install -d ${D}${bindir} |
| install -m 0755 mmc ${D}${bindir} |
| } |