| SUMMARY = "GNU grep utility" |
| HOMEPAGE = "http://savannah.gnu.org/projects/grep/" |
| BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep" |
| SECTION = "console/utils" |
| LICENSE = "GPLv3" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee" |
| |
| SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \ |
| file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
| " |
| |
| SRC_URI[md5sum] = "f46aa9d0d2577b9212a104348a286787" |
| SRC_URI[sha256sum] = "54fc478ee1ce17780109820ef30730c9e18715a949f7d5c6afc673adb2a56ecf" |
| |
| inherit autotools gettext texinfo |
| |
| EXTRA_OECONF = "--disable-perl-regexp" |
| |
| do_configure_prepend () { |
| rm -f ${S}/m4/init.m4 |
| } |
| |
| do_install () { |
| autotools_do_install |
| if [ "${base_bindir}" != "${bindir}" ]; then |
| install -d ${D}${base_bindir} |
| mv ${D}${bindir}/grep ${D}${base_bindir}/grep |
| mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep |
| mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep |
| rmdir ${D}${bindir}/ |
| fi |
| } |
| |
| inherit update-alternatives |
| |
| ALTERNATIVE_PRIORITY = "100" |
| |
| ALTERNATIVE_${PN} = "grep egrep fgrep" |
| ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" |
| ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" |
| ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" |
| |
| export CONFIG_SHELL="/bin/sh" |