| SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video." |
| DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \ |
| mux, demux, stream, filter and play pretty much anything that humans and machines \ |
| have created. It supports the most obscure ancient formats up to the cutting edge." |
| HOMEPAGE = "https://www.ffmpeg.org/" |
| SECTION = "libs" |
| |
| LICENSE = "GPLv2+" |
| LICENSE_FLAGS = "commercial" |
| |
| LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \ |
| file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| |
| SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz" |
| |
| SRC_URI[md5sum] = "ef9b6634bb7c920efc940b4d55adf7b2" |
| SRC_URI[sha256sum] = "12f32cee41c74435f608c30793fd616bdf53467bb513278e273e135a4c58e470" |
| |
| # Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717 |
| ARM_INSTRUCTION_SET = "arm" |
| |
| # Should be API compatible with libav (which was a fork of ffmpeg) |
| # libpostproc was previously packaged from a separate recipe |
| PROVIDES = "libav libpostproc" |
| |
| DEPENDS = "alsa-lib zlib libogg yasm-native" |
| |
| inherit autotools pkgconfig |
| |
| PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc \ |
| bzlib gpl lzma theora x264 \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xv', '', d)}" |
| |
| # libraries to build in addition to avutil |
| PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice" |
| PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter" |
| PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec" |
| PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat" |
| PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample" |
| PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale" |
| PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc" |
| PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample" |
| |
| # features to support |
| PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2" |
| PACKAGECONFIG[faac] = "--enable-libfaac,--disable-libfaac,faac" |
| PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl" |
| PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm" |
| PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack" |
| PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis" |
| PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz" |
| PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame" |
| PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| PACKAGECONFIG[schroedinger] = "--enable-libschroedinger,--disable-libschroedinger,schroedinger" |
| PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex" |
| PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora" |
| PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva" |
| PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx" |
| PACKAGECONFIG[x11] = "--enable-x11grab,--disable-x11grab,virtual/libx11 libxfixes libxext xproto virtual/libsdl" |
| PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264" |
| PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv" |
| |
| # Check codecs that require --enable-nonfree |
| USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'faac', 'openssl' ], 'yes', '', d)}" |
| |
| EXTRA_OECONF = " \ |
| --disable-stripping \ |
| --enable-pic \ |
| --enable-shared \ |
| --enable-pthreads \ |
| ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \ |
| \ |
| --cross-prefix=${TARGET_PREFIX} \ |
| \ |
| --ld="${CCLD}" \ |
| --arch=${TARGET_ARCH} \ |
| --target-os="linux" \ |
| --enable-cross-compile \ |
| --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ |
| --extra-ldflags="${TARGET_LDFLAGS}" \ |
| --sysroot="${STAGING_DIR_TARGET}" \ |
| --enable-hardcoded-tables \ |
| ${EXTRA_FFCONF} \ |
| --libdir=${libdir} \ |
| --shlibdir=${libdir} \ |
| --datadir=${datadir}/ffmpeg \ |
| " |
| |
| do_configure() { |
| ${S}/configure ${EXTRA_OECONF} |
| } |
| |
| PACKAGES_DYNAMIC += "^lib(av(codec|device|filter|format|util|resample)|swscale|swresample|postproc).*" |
| |
| # ffmpeg disables PIC on some platforms (e.g. x86-32) |
| INSANE_SKIP_${MLPREFIX}libavcodec = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavdevice = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavfilter = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavformat = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavutil = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavresample = "textrel" |
| INSANE_SKIP_${MLPREFIX}libswscale = "textrel" |
| INSANE_SKIP_${MLPREFIX}libswresample = "textrel" |
| INSANE_SKIP_${MLPREFIX}libpostproc = "textrel" |
| |
| python populate_packages_prepend() { |
| av_libdir = d.expand('${libdir}') |
| av_pkgconfig = d.expand('${libdir}/pkgconfig') |
| |
| # Runtime package |
| do_split_packages(d, av_libdir, '^lib(.*)\.so\..*', |
| output_pattern='lib%s', |
| description='libav %s library', |
| extra_depends='', |
| prepend=True, |
| allow_links=True) |
| |
| # Development packages (-dev, -staticdev) |
| do_split_packages(d, av_libdir, '^lib(.*)\.so$', |
| output_pattern='lib%s-dev', |
| description='libav %s development package', |
| extra_depends='${PN}-dev', |
| prepend=True, |
| allow_links=True) |
| do_split_packages(d, av_pkgconfig, '^lib(.*)\.pc$', |
| output_pattern='lib%s-dev', |
| description='libav %s development package', |
| extra_depends='${PN}-dev', |
| prepend=True) |
| do_split_packages(d, av_libdir, '^lib(.*)\.a$', |
| output_pattern='lib%s-staticdev', |
| description='libav %s development package - static library', |
| extra_depends='${PN}-dev', |
| prepend=True, |
| allow_links=True) |
| |
| } |