blob: 8efef0b47b2fa3f29f309c83d4e8ebad917a198d [file] [log] [blame]
SUMMARY = "Hardware Diagnostics for POWER Systems"
DESCRIPTION = \
"In the event of a system fatal error reported by the internal system \
hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
POWER Systems have the ability to diagnose the root cause of the failure \
and perform any service action needed to avoid repeated system failures."
HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
PR = "r1"
PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SRCREV = "0f481a441fa8102602a2e34403e14716324b9e5e"
S = "${WORKDIR}/git"
inherit meson systemd
SYSTEMD_SERVICE:${PN} = "attn_handler.service"
DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
nlohmann-json valijson"
# This is required so that libhei is installed with the chip data files.
RDEPENDS:${PN} += "openpower-libhei"
# Conditionally pull in PHAL APIs, if available.
PACKAGECONFIG ??= "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, ipl pdata"