| SUMMARY = "Convert text file line endings between CRLF and LF" |
| DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \ |
| unix2dos to convert plain text files in DOS or Mac format to Unix \ |
| HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html" |
| LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1b78fca784db24f4a40e30b300787f3f" |
| SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix" |
| SRCREV = "1182533bde3c1fe65be2ead465e87671faa2c027" |
| S = "${WORKDIR}/git/dos2unix" |
| inherit gettext perlnative |
| # The dos2unix NLS relies on po4a-native, while po4a recipe is |
| # provided by meta-perl layer, so make it optional here, you |
| # need have meta-perl in bblayers.conf before enabling nls in |
| PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native" |
| EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'" |
| EXTRA_OEMAKE_class-native = "ENABLE_NLS=" |
| oe_runmake DESTDIR="${D}${base_prefix}" install |
| BBCLASSEXTEND = "native nativesdk" |