| SUMMARY = "Witherspoon AVSBus control" |
| LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| inherit obmc-phosphor-systemd |
| RDEPENDS_${PN} += "i2c-tools" |
| SRC_URI += "file://avsbus-disable.sh \ |
| install -m 0755 ${S}/avsbus-disable.sh ${D}${bindir}/avsbus-disable.sh |
| install -m 0755 ${S}/avsbus-enable.sh ${D}${bindir}/avsbus-enable.sh |
| TMPL_EN= "avsbus-enable@.service" |
| TMPL_DIS= "avsbus-disable@.service" |
| INSTFMT_EN= "avsbus-enable@{0}.service" |
| INSTFMT_DIS= "avsbus-disable@{0}.service" |
| TGTFMT = "obmc-chassis-poweron@{0}.target" |
| FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}" |
| FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}" |
| SYSTEMD_SERVICE_${PN} += "${TMPL_EN}" |
| SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}" |
| SYSTEMD_SERVICE_${PN} += "${TMPL_DIS}" |
| SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}" |