| require ${BPN}.inc |
| |
| DEFAULT_PREFERENCE = "-1" |
| |
| SRCREV = "ea0d1f575c214c09ba3df12644a960e86e031766" |
| PV = "10.5.4+git${SRCPV}" |
| |
| SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;branch=10.5" |
| |
| S = "${WORKDIR}/git" |
| |
| DEPENDS += "python-mako-native" |
| |
| inherit pythonnative |
| |
| #because we cannot rely on the fact that all apps will use pkgconfig, |
| #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER |
| do_install_append() { |
| if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then |
| sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h |
| fi |
| } |