| SUMMARY = "The PyPA recommended tool for installing Python packages" |
| HOMEPAGE = "https://pypi.python.org/pypi/pip" |
| SECTION = "devel/python" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| |
| DEPENDS += "python3 python3-setuptools-native" |
| |
| SRC_URI[md5sum] = "526fd9ec1e6ea956b3571ebfb42cf83c" |
| SRC_URI[sha256sum] = "f851133f8b58283fa50d8c78675eb88d4ff4cde29b6c41205cd938b06338e0e5" |
| |
| inherit pypi distutils3 |
| |
| do_install_append() { |
| # Install as pip3 and leave pip2 as default |
| rm ${D}/${bindir}/pip |
| } |
| |
| RDEPENDS_${PN} = "\ |
| python3-compile \ |
| python3-io \ |
| python3-html \ |
| python3-json \ |
| python3-netserver \ |
| python3-setuptools \ |
| python3-unixadmin \ |
| python3-xmlrpc \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |