| SUMMARY = "Tools for managing kernel packet filtering capabilities" |
| DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \ |
| filtering code in Linux." |
| HOMEPAGE = "http://www.netfilter.org/" |
| BUGTRACKER = "http://bugzilla.netfilter.org/" |
| LICENSE = "GPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\ |
| file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc" |
| |
| RRECOMMENDS_${PN} = "kernel-module-x-tables \ |
| kernel-module-ip-tables \ |
| kernel-module-iptable-filter \ |
| kernel-module-iptable-nat \ |
| kernel-module-nf-defrag-ipv4 \ |
| kernel-module-nf-conntrack \ |
| kernel-module-nf-conntrack-ipv4 \ |
| kernel-module-nf-nat \ |
| kernel-module-ipt-masquerade" |
| FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables" |
| FILES_${PN}-dbg =+ "${libdir}/xtables/.debug" |
| |
| SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \ |
| file://types.h-add-defines-that-are-required-for-if_packet.patch \ |
| file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \ |
| file://0001-fix-build-with-musl.patch \ |
| file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \ |
| " |
| |
| SRC_URI[md5sum] = "536d048c8e8eeebcd9757d0863ebb0c0" |
| SRC_URI[sha256sum] = "52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0" |
| |
| inherit autotools pkgconfig |
| |
| EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \ |
| " |
| PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ |
| " |
| |
| PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| |
| # libnfnetlink recipe is in meta-networking layer |
| PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack" |
| |
| do_configure_prepend() { |
| # Remove some libtool m4 files |
| # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive. |
| rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 |
| } |