| do_listtasks[nostamp] = "1" |
| if d.getVarFlag(e, 'task'): |
| maxlen = max(maxlen, len(e)) |
| if e.endswith('_setscene'): |
| desc = "%s (setscene version)" % (d.getVarFlag(e[:-9], 'doc') or '') |
| desc = d.getVarFlag(e, 'doc') or '' |
| tasks = sorted(taskdescs.keys()) |
| bb.plain("%s %s" % (taskname.ljust(maxlen), taskdescs[taskname])) |
| T_task-clean = "${LOG_DIR}/cleanlogs/${PN}" |
| """clear the build and temp directories""" |
| dir = d.expand("${WORKDIR}") |
| bb.note("Removing " + dir) |
| dir = "%s.*" % d.getVar('STAMP') |
| bb.note("Removing " + dir) |
| for f in (d.getVar('CLEANFUNCS') or '').split(): |
| do_checkuri[nostamp] = "1" |
| src_uri = (d.getVar('SRC_URI') or "").split() |
| fetcher = bb.fetch2.Fetch(src_uri, d) |
| except bb.fetch2.BBFetchException as e: |