| SUMMARY = "Download, build, install, upgrade, and uninstall Python packages" |
| HOMEPAGE = "https://pypi.org/project/setuptools" |
| LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6" |
| inherit pypi python_setuptools_build_meta |
| SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch" |
| file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch" |
| SRC_URI[sha256sum] = "2ee892cd5f29f3373097f5a814697e397cf3ce313616df0af11231e2ad118077" |
| DEPENDS += "${PYTHON_PN}" |
| ${PYTHON_PN}-compression \ |
| ${PYTHON_PN}-pkg-resources \ |
| BBCLASSEXTEND = "native nativesdk" |
| # The pkg-resources module can be used by itself, without the package downloader |
| # and easy_install. Ship it in a separate package so that it can be used by |
| PACKAGES =+ "${PYTHON_PN}-pkg-resources " |
| FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*" |
| RDEPENDS:${PYTHON_PN}-pkg-resources = "\ |
| ${PYTHON_PN}-compression \ |
| # This used to use the bootstrap install which didn't compile. Until we bump the |
| # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |