Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 4 | |
| 5 | CVE_PRODUCT = "libtiff" |
| 6 | |
| 7 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 8 | file://CVE-2019-6128.patch \ |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame^] | 9 | file://CVE-2019-7663.patch \ |
| 10 | file://CVE-2019-14973.patch \ |
| 11 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | SRC_URI[md5sum] = "114192d7ebe537912a2b97408832e7fd" |
| 13 | SRC_URI[sha256sum] = "2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4" |
| 14 | |
| 15 | # exclude betas |
| 16 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 17 | |
| 18 | inherit autotools multilib_header |
| 19 | |
| 20 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 21 | |
| 22 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 23 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 24 | |
| 25 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 26 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 27 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 28 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 29 | |
| 30 | # Convert single-strip uncompressed images to multiple strips of specified |
| 31 | # size (default: 8192) to reduce memory usage |
| 32 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 33 | |
| 34 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 35 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 36 | |
| 37 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 38 | # the tag |
| 39 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 40 | |
| 41 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 42 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 43 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 44 | |
| 45 | PACKAGES =+ "tiffxx tiff-utils" |
| 46 | FILES_tiffxx = "${libdir}/libtiffxx.so.*" |
| 47 | FILES_tiff-utils = "${bindir}/*" |
| 48 | |
| 49 | do_install_append() { |
| 50 | oe_multilib_header tiffconf.h |
| 51 | } |
| 52 | |
| 53 | BBCLASSEXTEND = "native" |