Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 1 | SUMMARY = "New set of tools for working with SquashFS images" |
| 2 | SECTION = "base" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-3.0-or-later & LGPL-3.0-or-later & MIT & BSD-2-Clause & Zlib" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING.md;md5=5789fb0572753ed69014cd90a445cd74 \ |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 5 | file://licenses/GPLv3.txt;md5=1ebbd3e34237af26da5dc08a4e440464 \ |
| 6 | file://licenses/hash_table.txt;md5=874823605326caeaabaa95bfbd0f9fb0 \ |
| 7 | file://licenses/LGPLv3.txt;md5=3000208d539ec061b899bce1d9ce9404 \ |
| 8 | file://licenses/LZ4.txt;md5=ebc2ea4814a64de7708f1571904b32cc \ |
| 9 | file://licenses/xxhash.txt;md5=f042a9be092bd6d7fe6f217d8d00f4ca \ |
| 10 | file://licenses/xz.txt;md5=1c389b9610ccfdb25f7abaea6a0bb5a4 \ |
| 11 | file://licenses/zlib.txt;md5=ae27c72096606131f760e5f59cf98b06 \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 12 | file://licenses/zstd.txt;md5=8df8137b630239cbdd4c0674124cb0c8 \ |
| 13 | " |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 14 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 15 | SRCREV = "7667b84cc34707c28ca0db8d24f046ec34e8c25d" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | SRC_URI = "git://github.com/AgentD/squashfs-tools-ng.git;protocol=https;branch=master" |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig |
| 21 | |
| 22 | PACKAGECONFIG ??= "gzip xz lzo lz4 zstd ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}" |
| 23 | PACKAGECONFIG[gzip] = "--with-gzip,--without-gzip,zlib" |
| 24 | PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz" |
| 25 | PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo" |
| 26 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4" |
| 27 | PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd" |
| 28 | PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux" |
| 29 | |
| 30 | PACKAGES =+ "libsquashfs" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | FILES:libsquashfs = "${libdir}/libsquashfs*${SOLIBS}" |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |