blob: cb1db8c604844c2a2b9077854d486684c876d640 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001HOMEPAGE = "http://www.pyyaml.org"
2SUMMARY = "Python support for YAML"
3DESCRIPTION = "\
4 YAML is a data serialization format designed for human readability \
5 and interaction with scripting languages. PyYAML is a YAML parser \
6 and emitter for Python. \
7 . \
8 PyYAML features a complete YAML 1.1 parser, Unicode support, pickle \
9 support, capable extension API, and sensible error messages. PyYAML \
10 supports standard YAML tags and provides Python-specific tags that \
11 allow to represent an arbitrary Python object. \
12 . \
13 PyYAML is applicable for a broad range of tasks from complex \
14 configuration files to object serialization and persistance. \
15 "
16SECTION = "devel/python"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
19
20SRCNAME = "PyYAML"
21SRC_URI = "http://pyyaml.org/download/pyyaml/${SRCNAME}-${PV}.tar.gz"
22
23SRC_URI[md5sum] = "f50e08ef0fe55178479d3a618efe21db"
24SRC_URI[sha256sum] = "c36c938a872e5ff494938b33b14aaa156cb439ec67548fcab3535bb78b0846e8"
25
26S = "${WORKDIR}/${SRCNAME}-${PV}"
27
28inherit setuptools
29
30DEPENDS += "libyaml python-cython-native"