Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Mesa demo applications" |
| 2 | DESCRIPTION = "This package includes the demonstration application, such as glxgears. \ |
| 3 | These applications can be used for Mesa validation and benchmarking." |
| 4 | HOMEPAGE = "http://mesa3d.org" |
| 5 | BUGTRACKER = "https://bugs.freedesktop.org" |
| 6 | SECTION = "x11" |
| 7 | |
| 8 | LICENSE = "MIT & PD" |
| 9 | LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \ |
| 10 | file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06" |
| 11 | |
| 12 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \ |
| 13 | file://0001-mesa-demos-Add-missing-data-files.patch \ |
| 14 | file://0002-Correctly-implement-with-AC_WITH-glut-so-that-withou.patch \ |
| 15 | file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \ |
| 16 | file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \ |
| 17 | file://0005-Fix-build-when-EGL_MESA_screen_surface-extension-isn.patch \ |
| 18 | file://0006-Query-display-for-EGL_MESA_screen_surface-extension-.patch \ |
| 19 | file://0007-Install-few-more-test-programs.patch \ |
| 20 | file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \ |
| 21 | file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \ |
| 22 | " |
| 23 | SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061" |
| 24 | SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92" |
| 25 | |
| 26 | inherit autotools pkgconfig |
| 27 | |
| 28 | PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu', '', d)}" |
| 30 | |
| 31 | # The Wayland code doesn't work with Wayland 1.0, so disable it for now |
| 32 | #${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}" |
| 33 | |
| 34 | EXTRA_OECONF = "--with-system-data-files" |
| 35 | |
| 36 | PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm" |
| 37 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" |
| 38 | PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype" |
| 39 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl" |
| 40 | PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1" |
| 41 | PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2" |
| 42 | PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut," |
| 43 | PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa," |
| 44 | PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg" |
| 45 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland" |
| 46 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11" |
| 47 | PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew" |
| 48 | PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl" |
| 49 | |
| 50 | do_install_append() { |
| 51 | # it can be completely empty when all PACKAGECONFIG options are disabled |
| 52 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 53 | |
| 54 | if [ -f ${D}${bindir}/clear ]; then |
| 55 | mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos |
| 56 | fi |
| 57 | } |