Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides a bridge between gconf and xsettings" |
| 2 | HOMEPAGE = "http://svn.o-hand.com/view/matchbox/trunk/settings-daemon/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | LICENSE = "MIT-style" |
| 5 | LIC_FILES_CHKSUM = "file://xsettings-manager.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \ |
| 6 | file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b" |
| 7 | DEPENDS = "gconf glib-2.0 gtk+" |
| 8 | SECTION = "x11" |
| 9 | SRCREV = "9a99528b02255450db81176abd9bbcc1dab9a4c1" |
| 10 | PV = "0.0+git${SRCPV}" |
| 11 | |
| 12 | |
| 13 | SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \ |
| 14 | file://addsoundkeys.patch;apply=yes \ |
| 15 | file://70settings-daemon.sh \ |
| 16 | file://dso_linking_change_build_fix.patch" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig gconf distro_features_check |
| 21 | |
| 22 | FILES_${PN} = "${bindir}/* ${sysconfdir}" |
| 23 | |
| 24 | # Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES |
| 25 | REQUIRED_DISTRO_FEATURES = "x11" |
| 26 | |
| 27 | do_install_append () { |
| 28 | install -d ${D}/${sysconfdir}/X11/Xsession.d |
| 29 | install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/ |
| 30 | } |