Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME bluetooth manager" |
| 2 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ |
| 5 | file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 6 | " |
| 7 | |
| 8 | SECTION = "x11/gnome" |
| 9 | |
| 10 | DEPENDS = " \ |
| 11 | udev \ |
| 12 | libnotify \ |
| 13 | libcanberra \ |
| 14 | bluez5 \ |
| 15 | upower \ |
| 16 | gtk4 \ |
| 17 | gsound \ |
| 18 | libadwaita \ |
| 19 | " |
| 20 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 21 | GNOMEBASEBUILDCLASS = "meson" |
| 22 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 23 | GTKIC_VERSION = "4" |
| 24 | |
| 25 | inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection |
| 26 | |
| 27 | REQUIRED_DISTRO_FEATURES = "x11" |
| 28 | |
| 29 | SRC_URI[archive.sha256sum] = "3d1e2720673bc9a242619dc5d231fd6e776c18a49da29f43cdc433055adb0170" |
| 30 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 31 | BT_PULSE_PACKS = " \ |
| 32 | pulseaudio-lib-bluez5-util \ |
| 33 | pulseaudio-module-bluetooth-discover \ |
| 34 | pulseaudio-module-bluetooth-policy \ |
| 35 | pulseaudio-module-bluez5-device \ |
| 36 | pulseaudio-module-bluez5-discover \ |
| 37 | " |
| 38 | |
| 39 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}" |
| 40 | PACKAGECONFIG[pulseaudio] = ",,,${BT_PULSE_PACKS}" |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 41 | |
| 42 | FILES:${PN} += "${datadir}/gnome-bluetooth-3.0" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 43 | |
| 44 | RDEPENDS:${PN} += "bluez5" |