Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | # Copyright (C) 2016 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Open-source software for volunteer computing" |
| 5 | DESCRIPTION = "The Berkeley Open Infrastructure for Network Computing (BOINC) is an open- \ |
| 6 | source software platform which supports distributed computing, primarily in \ |
| 7 | the form of volunteer computing and desktop Grid computing. It is well \ |
| 8 | suited for problems which are often described as trivially parallel. BOINC \ |
| 9 | is the underlying software used by projects such as SETI@home, Einstein@Home, \ |
| 10 | ClimatePrediciton.net, the World Community Grid, and many other distributed \ |
| 11 | computing projects. \ |
| 12 | This package installs the BOINC client software, which will allow your \ |
| 13 | computer to participate in one or more BOINC projects, using your spare \ |
| 14 | computer time to search for cures for diseases, model protein folding, study \ |
| 15 | global warming, discover sources of gravitational waves, and many other types \ |
| 16 | of scientific and mathematical research." |
| 17 | |
| 18 | HOMEPAGE = "http://boinc.berkeley.edu/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 19 | LICENSE = "LGPL-2.0-or-later & GPL-3.0-only" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 20 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 21 | file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6" |
| 22 | SECTION = "applications" |
| 23 | DEPENDS = "curl \ |
| 24 | jpeg \ |
| 25 | openssl \ |
| 26 | sqlite3 \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 27 | virtual/egl \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libnotify', '', d)} \ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+ libnotify xcb-util libxscrnsaver', '', d)} \ |
| 30 | nettle \ |
| 31 | " |
| 32 | SRCREV = "b49adfb118211e11c719766c0d71e7bdfe7f3363" |
| 33 | BRANCH = "client_release/7/7.18" |
| 34 | SRC_URI = "git://github.com/BOINC/boinc;protocol=https;branch=${BRANCH} \ |
| 35 | file://boinc-AM_CONDITIONAL.patch \ |
| 36 | file://gtk-configure.patch \ |
| 37 | file://4563.patch \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 38 | file://0001-scripts-Do-not-check-for-files-on-build-host.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 39 | " |
| 40 | |
| 41 | inherit gettext autotools pkgconfig features_check systemd |
| 42 | |
| 43 | REQUIRED_DISTRO_FEATURES += "opengl" |
| 44 | |
| 45 | S = "${WORKDIR}/git" |
| 46 | |
| 47 | EXTRA_OECONF += "\ |
| 48 | --enable-libraries \ |
| 49 | --enable-unicode \ |
| 50 | --enable-shared \ |
| 51 | --enable-dynamic-client-linkage \ |
| 52 | --enable-client \ |
| 53 | --disable-server \ |
| 54 | --disable-static \ |
| 55 | --disable-manager \ |
| 56 | --with-ssl=${STAGING_EXECPREFIXDIR} \ |
| 57 | --without-wxdir \ |
| 58 | --without-x \ |
| 59 | --with-boinc-platform=${TARGET_SYS} \ |
| 60 | ac_cv_c_undeclared_builtin_options='none' \ |
| 61 | " |
| 62 | export PKG_CONFIG = "${STAGING_BINDIR_NATIVE}/pkg-config" |
| 63 | |
| 64 | do_configure:prepend () { |
| 65 | if [ "${@bb.utils.contains('DEPENDS', 'gtk+', '1', '0', d)}" = "0" ] |
| 66 | then |
| 67 | export GTK2_CFLAGS="" |
| 68 | export GTK2_LIBS="" |
| 69 | fi |
| 70 | } |
| 71 | |
| 72 | do_compile:prepend () { |
| 73 | # Disable rpaths |
| 74 | sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${B}/libtool |
| 75 | sed -i -e 's|^sys_lib_dlsearch_path_spec=.*|sys_lib_dlsearch_path_spec=""|g' ${B}/libtool |
| 76 | sed -i -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${B}/libtool |
| 77 | } |
| 78 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 79 | do_install:prepend() { |
| 80 | # help script install a bit to do right thing for OE |
| 81 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 82 | mkdir -p ${D}${systemd_system_unitdir} |
| 83 | else |
| 84 | mkdir -p ${D}${sysconfdir}/init.d |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 85 | fi |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 86 | mkdir -p ${D}${sysconfdir}/default |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 87 | } |
| 88 | |
| 89 | SYSTEMD_SERVICE:${PN} = "boinc-client.service" |
| 90 | |
| 91 | FILES:${PN} += "${libdir}/systemd" |