Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Ice Window Manager (IceWM)" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b" |
| 4 | |
| 5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \ |
| 6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ |
| 7 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 8 | SRC_URI[sha256sum] = "f8f453fc1f0009e3e7f113fd128638770894d004a3b60202922e2c7347c30607" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
| 10 | UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases" |
| 11 | |
| 12 | inherit autotools pkgconfig gettext perlnative features_check qemu update-alternatives |
| 13 | REQUIRED_DISTRO_FEATURES = "x11" |
| 14 | |
| 15 | EXTRA_OECONF += "--with-libdir=${datadir}/icewm \ |
| 16 | --with-cfgdir=${sysconfdir}/icewm \ |
| 17 | --with-docdir=${docdir}/icewm \ |
| 18 | --enable-fribidi \ |
| 19 | --enable-xinerama \ |
| 20 | --enable-shape" |
| 21 | |
| 22 | DEPENDS = "asciidoc-native fontconfig fribidi gdk-pixbuf imlib2 libxft libxpm libxrandr \ |
| 23 | libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \ |
| 24 | libxfixes" |
| 25 | DEPENDS:append = " qemu-native" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 26 | RDEPENDS:${PN} = "perl fribidi imlib2 imlib2-loaders" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 27 | |
| 28 | do_compile:prepend:class-target() { |
| 29 | |
| 30 | cd ${B} |
| 31 | oe_runmake -C src genpref |
| 32 | |
| 33 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}',['${B}/src/.libs','${STAGING_DIR_TARGET}/${libdir}','${STAGING_DIR_TARGET}/${base_libdir}'])}" |
| 34 | cat >qemuwrapper <<EOF |
| 35 | #!/bin/sh |
| 36 | ${qemu_binary} src/genpref "\$@" |
| 37 | EOF |
| 38 | chmod +x qemuwrapper |
| 39 | ./qemuwrapper > src/preferences |
| 40 | } |
| 41 | |
| 42 | ALTERNATIVE:${PN} = "x-session-manager" |
| 43 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/icewm-session" |
| 44 | ALTERNATIVE_PRIORITY_${PN} = "100" |
| 45 | |
| 46 | FILES:${PN} += "${datadir}/xsessions" |