Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | HOMEPAGE = "https://lttng.org/" |
| 5 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4" |
| 7 | |
| 8 | inherit module |
| 9 | |
| 10 | include lttng-platforms.inc |
| 11 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 12 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 13 | file://0001-Fix-compaction-migratepages-event-name.patch \ |
| 14 | file://0002-Fix-tracepoint-event-allow-same-provider-and-event-n.patch \ |
| 15 | file://0003-fix-sched-tracing-Don-t-re-read-p-state-when-emittin.patch \ |
| 16 | file://0004-fix-block-remove-genhd.h-v5.18.patch \ |
| 17 | file://0005-fix-scsi-block-Remove-REQ_OP_WRITE_SAME-support-v5.1.patch \ |
| 18 | file://0006-fix-random-remove-unused-tracepoints-v5.18.patch \ |
| 19 | file://0007-fix-kprobes-Use-rethook-for-kretprobe-if-possible-v5.patch \ |
| 20 | file://0008-fix-scsi-core-Remove-scsi-scsi_request.h-v5.18.patch \ |
| 21 | file://0009-Rename-genhd-wrapper-to-blkdev.patch \ |
| 22 | file://0010-fix-mm-compaction-cleanup-the-compaction-trace-event.patch \ |
| 23 | " |
| 24 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 25 | # Use :append here so that the patch is applied also when using devupstream |
| 26 | SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch" |
| 27 | |
| 28 | SRC_URI[sha256sum] = "7cf1acbb50b84116acc9b4281b81dcc2643d6018bbd1e8514ad1270239896c4b" |
| 29 | |
| 30 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 31 | |
| 32 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 33 | |
| 34 | MODULES_MODULE_SYMVERS_LOCATION = "src" |
| 35 | |
| 36 | do_install:append() { |
| 37 | # Delete empty directories to avoid QA failures if no modules were built |
| 38 | if [ -d ${D}/${nonarch_base_libdir} ]; then |
| 39 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 40 | fi |
| 41 | } |
| 42 | |
| 43 | python do_package:prepend() { |
| 44 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 45 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 46 | } |
| 47 | |
| 48 | BBCLASSEXTEND = "devupstream:target" |
| 49 | SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13" |
| 50 | SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630" |
| 51 | SRCREV_FORMAT ?= "lttng_git" |