Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "There are two major versions of the PCRE library. The \ |
| 2 | newest version is PCRE2, which is a re-working of the original PCRE \ |
| 3 | library to provide an entirely new API. The original, very widely \ |
| 4 | deployed PCRE library's API and feature are stable, future releases \ |
| 5 | will be for bugfixes only. All new future features will be to PCRE2, \ |
| 6 | not the original PCRE 8.x series." |
| 7 | SUMMARY = "Perl Compatible Regular Expressions version 2" |
| 8 | HOMEPAGE = "http://www.pcre.org" |
| 9 | SECTION = "devel" |
| 10 | LICENSE = "BSD-3-Clause" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 11 | LIC_FILES_CHKSUM = "file://LICENCE;md5=41bfb977e4933c506588724ce69bf5d2" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
| 13 | SRC_URI = "https://github.com/PhilipHazel/pcre2/releases/download/pcre2-${PV}/pcre2-${PV}.tar.bz2" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/PhilipHazel/pcre2/releases" |
| 16 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 17 | SRC_URI[sha256sum] = "14e4b83c4783933dc17e964318e6324f7cae1bc75d8f3c79bc6969f00c159d68" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | |
| 19 | CVE_PRODUCT = "pcre2" |
| 20 | |
| 21 | S = "${WORKDIR}/pcre2-${PV}" |
| 22 | |
| 23 | PROVIDES += "pcre2" |
| 24 | DEPENDS += "bzip2 zlib" |
| 25 | |
| 26 | BINCONFIG = "${bindir}/pcre2-config" |
| 27 | |
| 28 | inherit autotools binconfig-disabled |
| 29 | |
| 30 | EXTRA_OECONF = "\ |
| 31 | --enable-newline-is-lf \ |
| 32 | --with-link-size=2 \ |
| 33 | --with-match-limit=10000000 \ |
| 34 | --enable-pcre2-16 \ |
| 35 | --enable-pcre2-32 \ |
| 36 | " |
| 37 | CFLAGS += "-D_REENTRANT" |
| 38 | CXXFLAGS:append:powerpc = " -lstdc++" |
| 39 | |
| 40 | PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc" |
| 41 | |
| 42 | SUMMARY:pcre2grep = "grep utility that uses perl 5 compatible regexes" |
| 43 | SUMMARY:pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs" |
| 44 | SUMMARY:pcre2test = "program for testing Perl-comatible regular expressions" |
| 45 | SUMMARY:pcre2test-doc = "program for testing Perl-comatible regular expressions - docs" |
| 46 | |
| 47 | FILES:libpcre2-16 = "${libdir}/libpcre2-16.so.*" |
| 48 | FILES:libpcre2-32 = "${libdir}/libpcre2-32.so.*" |
| 49 | FILES:pcre2grep = "${bindir}/pcre2grep" |
| 50 | FILES:pcre2grep-doc = "${mandir}/man1/pcre2grep.1" |
| 51 | FILES:pcre2test = "${bindir}/pcre2test" |
| 52 | FILES:pcre2test-doc = "${mandir}/man1/pcre2test.1" |
| 53 | |
| 54 | BBCLASSEXTEND = "native nativesdk" |