Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | LICENSE = "BSD-2-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf" |
| 4 | HOMEPAGE = "http://www.remotesensing.org/libtiff/" |
| 5 | |
| 6 | SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \ |
| 7 | file://libtool2.patch \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[md5sum] = "9aee7107408a128c0c7b24286c0db900" |
| 11 | SRC_URI[sha256sum] = "8cb1d90c96f61cdfc0bcf036acc251c9dbe6320334da941c7a83cfe1576ef890" |
| 12 | |
| 13 | inherit autotools |
| 14 | |
| 15 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 16 | |
| 17 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 18 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 19 | |
| 20 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 21 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 22 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 23 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 24 | |
| 25 | # Convert single-strip uncompressed images to multiple strips of specified |
| 26 | # size (default: 8192) to reduce memory usage |
| 27 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 28 | |
| 29 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 30 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 31 | |
| 32 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 33 | # the tag |
| 34 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 35 | |
| 36 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 37 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 38 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 39 | |
| 40 | PACKAGES =+ "tiffxx tiff-utils" |
| 41 | FILES_tiffxx = "${libdir}/libtiffxx.so.*" |
| 42 | FILES_tiff-utils = "${bindir}/*" |
| 43 | |
| 44 | BBCLASSEXTEND = "native" |