mustafa | e67e228 | 2021-03-29 15:08:45 -0500 | [diff] [blame] | 1 | SUMMARY = "Initialize PWM sensors" |
| 2 | DESCRIPTION = "Initialize PWM sensors" |
| 3 | LICENSE = "CLOSED" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | DEPENDS = "systemd" |
| 9 | RDEPENDS_${PN} = "bash" |
| 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 13 | SRC_URI += " \ |
| 14 | file://pwm_init.service \ |
| 15 | file://bin/pwm_init.sh \ |
| 16 | " |
| 17 | |
| 18 | SYSTEMD_PACKAGES = "${PN}" |
| 19 | SYSTEMD_AUTO_ENABLE = "enable" |
| 20 | SYSTEMD_SERVICE_${PN} += "pwm_init.service" |
| 21 | |
| 22 | FILES_${PN} += "${bindir}/* ${systemd_system_unitdir}/*" |
| 23 | |
| 24 | do_install_append() { |
| 25 | install -d ${D}${bindir} |
| 26 | install -m 0755 ${S}/bin/* ${D}${bindir}/ |
| 27 | install -d ${D}${systemd_system_unitdir} |
| 28 | install -m 0644 ${S}/*.service ${D}${systemd_system_unitdir} |
| 29 | } |