Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Collection of Vulkan examples" |
| 2 | LICENSE = "MIT" |
| 3 | DEPENDS = "zlib" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \ |
| 6 | file://triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa" |
| 7 | |
| 8 | SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \ |
| 9 | file://0001-Support-installing-demos-support-out-of-tree-builds.patch \ |
| 10 | file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \ |
| 11 | file://0001-Fix-build-on-x86.patch \ |
| 12 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | UPSTREAM_CHECK_COMMITS = "1" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | SRCREV = "18df00c7b4677b0889486e16977857aa987947e2" |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 19 | |
| 20 | inherit cmake distro_features_check |
| 21 | DEPENDS = "vulkan assimp" |
| 22 | |
| 23 | do_install_append () { |
| 24 | # Remove assets that have uncertain licenses |
| 25 | rm ${D}${datadir}/vulkan-demos/models/armor/* \ |
| 26 | ${D}${datadir}/vulkan-demos/models/sibenik/* \ |
| 27 | ${D}${datadir}/vulkan-demos/models/vulkanscene* \ |
| 28 | ${D}${datadir}/vulkan-demos/models/plants.dae \ |
| 29 | ${D}${datadir}/vulkan-demos/textures/texturearray_plants* |
| 30 | |
| 31 | mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot |
| 32 | } |
| 33 | |
| 34 | EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos" |
| 35 | |
| 36 | ANY_OF_DISTRO_FEATURES = "x11 wayland" |
| 37 | |
| 38 | # Can only pick one of [wayland,xcb] |
| 39 | PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}" |
| 40 | PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland" |
| 41 | PACKAGECONFIG[xcb] = ",,libxcb" |