Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "A partition editor to graphically manage disk partitions " |
| 2 | HOMEPAGE = "http://gparted.org/index.php" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | |
| 6 | inherit distro_features_check autotools pkgconfig gtk-icon-cache |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
| 12 | file://org.yoctoproject.pkexec.run-gparted.policy \ |
| 13 | file://gparted_polkit \ |
| 14 | " |
| 15 | SRC_URI[md5sum] = "2f481ad34decb7021ca04ca305e79e7d" |
| 16 | SRC_URI[sha256sum] = "5023b8c983f88a22e65bf6f09a12ea09369defc008981b52ee8b96a3879f81d6" |
| 17 | |
| 18 | DEPENDS = "glib-2.0 glib-2.0-native gtkmm parted gnome-doc-utils intltool-native" |
| 19 | |
| 20 | do_install_append() { |
| 21 | # Add a script which checks if polkit is installed. |
| 22 | # If yes: a policy is requested from polkit / otherwise start as usual |
| 23 | install ${WORKDIR}/gparted_polkit ${D}${sbindir} |
| 24 | sed -i 's:%sbindir%:${sbindir}:g' ${D}${sbindir}/gparted_polkit |
| 25 | # relink menu entry to use our script |
| 26 | sed -i 's:${sbindir}/gparted:${sbindir}/gparted_polkit:g' ${D}${datadir}/applications/gparted.desktop |
| 27 | |
| 28 | install -d ${D}${datadir}/polkit-1/actions |
| 29 | install ${WORKDIR}/org.yoctoproject.pkexec.run-gparted.policy ${D}${datadir}/polkit-1/actions/org.yoctoproject.pkexec.run-gparted.policy |
| 30 | } |
| 31 | |
| 32 | EXTRA_OECONF = "--disable-scrollkeeper --disable-doc" |
| 33 | |
| 34 | FILES_${PN} += " \ |
| 35 | ${datadir}/appdata \ |
| 36 | ${datadir}/icons \ |
| 37 | ${datadir}/polkit-1 \ |
| 38 | " |
| 39 | |
| 40 | RDEPENDS_${PN} = "dosfstools mtools e2fsprogs" |