Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Web-based MySQL administration interface" |
| 2 | HOMEPAGE = "http://www.phpmyadmin.net" |
| 3 | # Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT |
| 4 | LICENSE = "GPLv2 & LGPLv3 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 6 | file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=dd6470bbcd3436ca317f82d34abaf688 \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 7 | file://js/vendor/jquery/MIT-LICENSE.txt;md5=e43aa437a6a1ba421653bd5034333bf9 \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \ |
| 11 | file://apache.conf \ |
| 12 | " |
| 13 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "5b5d1d84a05624430ac659e36af00f4e" |
| 15 | SRC_URI[sha256sum] = "3bc3e37fefbdfcaf12fd59d6d7fdbf11ffcffe3e211155bf5b822b54a3c2043e" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://www.phpmyadmin.net/downloads/" |
| 18 | UPSTREAM_CHECK_REGEX = "phpMyAdmin-(?P<pver>\d+(\.\d+)+)-all-languages.tar.xz" |
| 19 | |
| 20 | S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages" |
| 21 | |
| 22 | inherit allarch |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${datadir}/${BPN} |
| 26 | cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN} |
| 27 | chown -R root:root ${D}${datadir}/${BPN} |
| 28 | # Don't install patches to target |
| 29 | rm -rf ${D}${datadir}/${BPN}/patches |
| 30 | |
| 31 | install -d ${D}${sysconfdir}/apache2/conf.d |
| 32 | install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf |
| 33 | |
| 34 | # Remove a few scripts that explicitly require bash (!) |
| 35 | rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh |
| 36 | } |
| 37 | |
| 38 | FILES_${PN} = "${datadir}/${BPN} \ |
| 39 | ${sysconfdir}/apache2/conf.d" |
| 40 | |
| 41 | RDEPENDS_${PN} += "bash php-cli" |