Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "An asynchronous event notification library" |
| 2 | HOMEPAGE = "http://libevent.org/" |
| 3 | BUGTRACKER = "https://github.com/libevent/libevent/issues" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "BSD & MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549" |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \ |
| 11 | file://Makefile-missing-test-dir.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame^] | 15 | SRC_URI[md5sum] = "7f35cfe69b82d879111ec0d7b7b1c531" |
| 16 | SRC_URI[sha256sum] = "a65bac6202ea8c5609fd5c7e480e6d25de467ea1917c08290c521752f147283d" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | |
| 18 | UPSTREAM_CHECK_URI = "http://libevent.org/" |
| 19 | |
| 20 | S = "${WORKDIR}/${BPN}-${PV}-stable" |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 24 | |
| 25 | inherit autotools |
| 26 | |
| 27 | # Needed for Debian packaging |
| 28 | LEAD_SONAME = "libevent-2.1.so" |
| 29 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | inherit ptest multilib_header |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | |
| 32 | DEPENDS = "zlib" |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |
| 35 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | do_install_append() { |
| 37 | oe_multilib_header event2/event-config.h |
| 38 | } |
| 39 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | do_install_ptest() { |
| 41 | install -d ${D}${PTEST_PATH}/test |
| 42 | for file in ${B}/test/.libs/regress ${B}/test/.libs/test* |
| 43 | do |
| 44 | install -m 0755 $file ${D}${PTEST_PATH}/test |
| 45 | done |
| 46 | } |