Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem" |
| 2 | SECTION = "base" |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/linuxquota/" |
| 4 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136" |
| 5 | LICENSE = "BSD & GPLv2+ & LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \ |
| 7 | file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb" |
| 8 | |
| 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \ |
| 10 | file://fcntl.patch \ |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame^] | 11 | file://0001-quota-Use-realloc-3-instead-of-reallocarray-3.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | " |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame^] | 13 | SRC_URI[sha256sum] = "2f3e03039f378d4f0d97acdb49daf581dcaad64d2e1ddf129495fd579fbd268d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | |
| 15 | CVE_PRODUCT = "linux_diskquota" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/linuxquota/files/quota-tools/" |
| 18 | UPSTREAM_CHECK_REGEX = "/quota-tools/(?P<pver>(\d+[\.\-_]*)+)/" |
| 19 | |
| 20 | DEPENDS = "gettext-native e2fsprogs libnl dbus" |
| 21 | |
| 22 | inherit autotools-brokensep gettext pkgconfig |
| 23 | |
| 24 | CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-I${STAGING_INCDIR}/tirpc', '', d)}" |
| 25 | LDFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-ltirpc', '', d)}" |
| 26 | ASNEEDED = "" |
| 27 | |
| 28 | PACKAGECONFIG ??= "tcp-wrappers rpc bsd" |
| 29 | PACKAGECONFIG_libc-musl = "tcp-wrappers rpc" |
| 30 | |
| 31 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 32 | PACKAGECONFIG[rpc] = "--enable-rpc,--disable-rpc,libtirpc" |
| 33 | PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no," |
| 34 | PACKAGECONFIG[ldapmail] = "--enable-ldapmail,--disable-ldapmail,openldap" |