vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC IPMI daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-host-ipmid" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit obmc-phosphor-license |
Patrick Williams | 89b11a1 | 2015-10-15 15:20:20 -0500 | [diff] [blame] | 7 | inherit obmc-phosphor-sdbus-service |
vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 8 | |
vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 9 | SRC_URI += "git://github.com/openbmc/phosphor-host-ipmid" |
| 10 | |
Patrick Williams | 89b11a1 | 2015-10-15 15:20:20 -0500 | [diff] [blame] | 11 | SRCREV = "98900a99254cd177c8308b63c341f793d2ac119d" |
vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | do_install() { |
Patrick Williams | 89b11a1 | 2015-10-15 15:20:20 -0500 | [diff] [blame] | 16 | install -m 0755 -d ${D}${sbindir} |
vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 17 | install -m 0755 ${S}/ipmid ${D}${sbindir}/ |
Patrick Williams | 89b11a1 | 2015-10-15 15:20:20 -0500 | [diff] [blame] | 18 | |
| 19 | install -m 0755 -d ${D}${libdir}/host-ipmid |
| 20 | install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/ |
| 21 | |
| 22 | install -m 0755 -d ${D}${includedir}/host-ipmid |
| 23 | install -m 0644 ${S}/ipmid-api.h ${D}${includedir}/host-ipmid/ |
vishwabmc | 2ac6f93 | 2015-10-09 15:51:50 +0530 | [diff] [blame] | 24 | } |