Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl interface to the SHA-1 algorithm " |
| 2 | DESCRIPTION = "Digest::SHA1 - Perl interface to the SHA-1 algorithm" |
| 3 | HOMEPAGE = "http://search.cpan.org/~gaas/Digest-SHA1-2.13/" |
| 4 | SECTION = "libs" |
| 5 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "Artistic-1.0|GPL-1.0-or-later" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://README;beginline=10;endline=14;md5=ff5867ebb4bc1103a7a416aef2fce00a" |
| 8 | |
| 9 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Digest-SHA1-${PV}.tar.gz \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "bd22388f268434f2b24f64e28bf1aa35" |
| 13 | SRC_URI[sha256sum] = "68c1dac2187421f0eb7abf71452a06f190181b8fc4b28ededf5b90296fb943cc" |
| 14 | |
| 15 | S = "${WORKDIR}/Digest-SHA1-${PV}" |
| 16 | |
| 17 | inherit cpan ptest |
| 18 | |
| 19 | do_install_ptest () { |
| 20 | cp -r ${B}/t ${D}${PTEST_PATH} |
| 21 | } |
| 22 | |
| 23 | BBCLASSEXTEND="native" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Digest/SHA1/.debug/" |