Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace utilities for fs-verity" |
| 2 | DESCRIPTION = "fs-verity is a Linux kernel feature that does transparent \ |
| 3 | on-demand integrity/authenticity verification of the contents of read-only \ |
| 4 | files, using a hidden Merkle tree (hash tree) associated with the file. The \ |
| 5 | mechanism is similar to dm-verity, but implemented at the file level rather \ |
| 6 | than at the block device level." |
| 7 | HOMEPAGE = "https://www.kernel.org/doc/html/latest/filesystems/fsverity.html" |
| 8 | SECTION = "console" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bc974d217b525ea216a336adb73e1220" |
| 11 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 12 | SRCREV = "9e082897d61a2449657651aa5a0931aca31428fd" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/ebiggers/fsverity-utils.git;branch=master" |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | DEPENDS = "openssl" |
| 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | EXTRA_OEMAKE:append = "PREFIX=${prefix} USE_SHARED_LIB=1" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 20 | # We want to statically link the binary to libfsverity on native Windows |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1" |
| 22 | EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1" |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 23 | |
| 24 | do_install() { |
| 25 | oe_runmake install DESTDIR=${D} |
| 26 | } |
| 27 | |
| 28 | PACKAGES =+ "libfsverity" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:libfsverity = "${libdir}/libfsverity*${SOLIBS}" |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |